Ebene (teilweise transparent) einheitlich einfärben: wie ohne Umwege?

Hier bekommst du Hilfestellungen zu GIMP
Antworten
joeditt
Beiträge: 1
Registriert: Mo 12. Feb 2024, 21:39
Betriebssystem: Windows 10 Home 22H2

Ebene (teilweise transparent) einheitlich einfärben: wie ohne Umwege?

Beitrag von joeditt »

Hallo!

Um eine Ebene mit transparenten Teilen rasch und einfach mit einer bestimmten (Vollton-)Farbe einzufärben, hat sich mir scheinbar der Dialog „Einfärben“ angeboten ... leider wirklich nur scheinbar. Oder (sehr) bedingt.

Weil ich schon einiges gebastelt habe, enthält er bereits insgesamt zwölf auswählbare Farben (mehr sind da anscheinend nicht unterzubringen: wird durch eine neue eine bisher enthaltene verdrängt?). Aber die verhalten sich unterschiedlich: Schwarz, Weiß, ein sehr helles Gelb sowie ein bronze/grau-gelber Ton (dessen Symbolfläche allerdings knallgelb dargestellt wird), werden übernommen: deren Wahl im Unterfenster „Farbe“ stellt die Teilfläche im Arbeitsfenster bereits vorschaumäßig eingefärbt dar, was nach abschließendem „OK“ im Dialog-Hauptfenster so bleibt bzw. auf „Abbrechen“ hin ebenso wunschgemäß wieder spurlos verschwindet. So weit, so fein.

Doch da sind noch acht weitere (eben nur) scheinbar wählbare Farben: die können im Unterfenster ebenso genau eingestellt werden, nur gibt es in diesen Fällen keine Vorschau-Reaktion, und auch das abschließende „OK“ bleibt folgenlos: eine Einfärbe-Funktion, die (so) nicht einfärbt. Besonders befremdlich: die zwei Gelb-Töne sind von mir: die funktionieren. Die anderen acht Farben sind auch alle von mir eingestellt und in die Auswahl per OK im Farbeinstellungs-Unterfenster eingefügt, funktionieren aber nicht. Noch befremdlicher: nach Aufruf des Dialogs wird das zum Unterfenster verlinkende Balkenfeld „Farbe“ in einem blassen Petrolblau angezeigt, das ursprünglich auch funktioniert hatte. Jetzt lässt es sich zwar im Farb-Unterfenster wählen, bleibt aber – trotz seiner der Aufrufstart-Darstellung gemäß zu vermutenden mysteriös prominenten Rolle – wirkungslos. Außerdem rätselhaft: einige der Farb-Symbolflächen haben eine violette rechte obere Ecke. Doch deckt sich das nicht mit der Einteilung in funktionierende und nicht funktionierende: reines Rot, Dunkelgrau, das notorische hellere Petrol sowie ein von mir neu eingestelltes Orange haben wie Schwarz, Weiß und die beiden Gelb-Tone keine solche Ecke, sind aber ebenso wirkungslos, wie die vier mit violetter Ecke im Symbolfeld (noch einmal Gelb, reines Blau, Hellblau sowie ein noch helleres Blau mit erhöhtem Grünanteil). Was sonst also zeigen diese violetten Ecken an?

Damit nicht genug, enthält das „Einfärben“-Dialogfenster ein optional hinter dem kryptisch mit „Mitteilung-Einstellungen“ bezeichneten Textlink-Knopf ein rätselhaft mit „Modus“ bezeichnetes Menü, zu dem ich trotz bemühter Suche keine Informationen finden kann. Es enthält so eigenwillige Punkte, wie „Normal“, „Vernichten“ oder „Hinter“, und meine bisherigen durchaus zahlreichen Versuche, davon irgendetwas durch Wahl anhand eines so bewirkten Ergebnisses zu testen, sind leer ausgegangen: sämtliche Menüpunkte sind bei mir bisher folgenlos geblieben.

Für mein eigentliches aktuelles Anliegen (die nicht transparente Teile einer Ebene durch wenige Klicks mit einem bestimmten Ton einheitlich einfärben) kenne ich zwar Umwege, aber sind ist eben welche, und zumindest der erste zeigt manchmal im Detail kleine, unerwünschte Unschärfen: sind die Ebenenteile farblich uneinheitlich, mache ich sie per „Einfärben“ komplett schwarz oder weiß, dann verwende ich die „Auswahl nach Farbe“, dann töne ich die Vorder- oder Hintergrundfarbe wie gewünscht, und dann färbe ich via Bearbeiten-Menü, pfff ... sicher, geht auch, dauert aber länger, und verhindert den direkten Erhalt einer u. U. auch danach noch öfters in einem ganz bestimmten Ton benötigten Vorder- oder Hintergrundfarbe. Und macht außerdem den gesamten „Einfärben“-Dialog offenbar sinnlos. Etwas präziser geht: Auswahl nach Farbe (nach Vereinheitlichung, u. U. in Form einer duplizierten Ebene), weitere neue Ebene in gewünschter Farbe (direkt bei Erstellung oder danach per Vorder- bzw. Hintergrundfarbe), erwähnte Auswahl invertieren und aus der neuen Wunschfarben-Ebene ausschneiden. Ebenfalls umständlich und von den Programmierenden sehr wahrscheinlich nicht so gedacht.

Was also muss ich tun, damit Einfärben aller nicht transparenten Teile einer Ebene eben über den offenbar genau dafür vorgesehenen Dialog mit jeder darin eingestellten Farbe funktioniert? Oder geht das mindestens so einfach ganz anders?

Mit schon ziemlich geröteten Augen,
Joe
Benutzeravatar
Gimplyworxs
Beiträge: 2654
Registriert: Sa 22. Aug 2020, 09:11
Wohnort: Crailsheim, BaWü
Deine Galerie: https://gimp-werkstatt.de/werkstatt-galerie/gimplyworxs
Betriebssystem: Linux Mint 20.1 MATE

Re: Ebene (teilweise transparent) einheitlich einfärben: wie ohne Umwege?

Beitrag von Gimplyworxs »

Hallo Joe,

Die magentafarbenen Dreiecke haben nichts damit zu tun, ob die Farben aktiv sind oder nicht.
Diese Farbe dient dazu, diejenigen zu kennzeichnen, die "außerhalb des Gamut" sind. D.h. dass sie in dem Farbraum deines Bildes nicht korrekt dargestellt werden können. (Die Fotografen hier können dir das sicher besser erklären als ich).

Du kannst den Farben Dialog ein wenig anpassen, damit er aussieht, wie man das so gewohnt ist:
Bild.
So zeigt es das viele Magenta nicht an.

Die Farbfelder sind deine zuletzt benutzen / von Hand hinzugefügten Farben. Bezieht sich nicht nur auf diesen Dialog.

Und die Mittelungs-Einstellungen ... damit kannst du festlegen, wie GIMP die neue Farbe mit der alten vermischen soll.
Normal ist hier "Ersetzen".

Wenn diese Farbwählerei bei dir nicht richtig funktioniert, würde ich als Erstes mal schauen, ob du ein RGB Bild hast (steht oben in der Titelleiste). Wenn nicht, dann mal umschalten unter Bild > Modus > RGB
Viele Grüße
Gimplyworxs

Bild
Antworten